Unsupported class version number [52.0] (maximum 51.0, Java 1.7) 에러 해결법

꾸준히 이클립스를 고집하며 빌드를 해오고 있지만


구글에서는 SDK 26 이하 버전은 이제 더 이상 새로 출시하거나 업데이트할 수 없다.



그래서 최소 8.0 이상 버전으로 올려서 빌드를 해야한다.


그런데 


Unsupported class version number [52.0] (maximum 51.0, Java 1.7)


빌드 시 이런 콘솔 에러가 나면서 apk 빌드가 안된다.



이것은 프로가드의 업데이트 문제였다.


https://sourceforge.net/projects/proguard/files/proguard/


이곳에서 최신 버전의 프로가드 zip 파일을 다운받은 후 


안드로이드 sdk가 설치된 곳에 넣어주면 된다.


C:\android-sdks\tools\proguard




그랬더니 


Failed to load C:\android-sdks\build-tools\26.0.3\lib\dx.jar


이런 오류가 나는 것이 아닌가?!



이것은 안드로이드 이클립스 adt를 더 이상 지원하지 않기 때문에 생기는 문제다.


편법이 있는데 


C:\android-sdks\build-tools


폴더에 보면 25.0.2 같은 25로 시작되는 폴더들이 있다.


이곳 안에 lib 폴더를 보면 dx.jar 파일이 있는데 


26.0.x 폴더 안의 lib 안에다 붙여넣기 한 후 빌드하면 드디어 apk로 말아진다.


이 글을 공유하기

댓글(0)

Designed by JB FACTORY